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1 General notes 

The function block has been tested with SIMATIC® S7-300 CPU 314C-2 PN/DP. 

The interface module was engineered with SIMATIC® Manager V5.5 + SP3. 

1.1 Requirements 

• Basic knowledge of handling and programming Siemens systems. 

• Familiarity with PROFINET. 

1.2 Liability 

SIKO GmbH assumes no warranty whatsoever regarding topicality, correctness, completeness 
or quality of the information or software products provided. All liability claims against SIKO 
GmbH referring to material or immaterial damages caused by using or not using the 
information or software provided or by using erroneous or incomplete information or software 
are always excluded. 

1.3 Versions overview 

This manual is related to the project "SIKO_example" and library "SIKO_AG2X_LIB_V100". 

1.4 List of abbreviations 

EPN PROFINET 

SW Status Word 

CW Control Word 
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2 Hardware configuration 

2.1 Create new project 

Before the hardware can be used it must be configured first. Therefore we have to create a 
new project. 

1. Start the SIMATIC® Manger and create a new project. 

2. Enter the name of the project, for example "SIKO_example".  

3. Select the project name on the left side. 

 

4. Insert a new S7-300 station by using the command  
    "Insert" > "Station" > "SIMATIC 300 Station". 

 
The new station appears below the project name. 

5. Select the new station on the left side. 

 

 

6. Open the hardware configuration tool with command "Edit" > "Open Object". 
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Now a emty hardware configuration window is opened. 

7. Install GSD for AG2X via command "Options" > "Install GSD File…" 

 
 

8. Browse to the storage location of the GSD file and choose the actual version. 

9. Install the selected file.  
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After installation the AG2X is available in the hardware catalog. 

 

10. Choose "Rail" from the folder "RACK-300" of the hardware catalog on the right side. Use 
drag and drop to move the "Rail" to the hardware configuration. 

  
11. Choose the CPU from the hardware catalog and plug it into slot 2 of the rail. 
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Now the "Properties - Ethernet interface" window appears. 

 
12. Enter a valid IP address and subnet mask. 

 

13. Create a new Subnet. 
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14. Confirm the settings with "OK" 

15. Close the "Properties - Ethernet interface" window. 

 

16. Choose "DAP" within the folder "AG2X" from the hardware catalog and attach it to the 
PROFINET subnet using drag and drop. 

 
 

17. Open the properties window of the AG2X by double clicking on the drive symbol.  
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18. Enter a device name. 

19. Enter a valid IP address. 

 

20. Confirm the settings with "OK". 

21. Save and compile the hardware configuration. 

 
22. Close "HW Config". 

The hardware configuration of the project is now complete. 
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2.2 Communication settings 

After setup of the project the hardware must be configured. 

2.2.1 Display accessible nodes 

1. Execute the command "PLC" > "Edit Ethernet Node…" 

2. Use the "Browse" button to find accessible nodes. 

 

3. Choose decvice type "SIKO-AG2X" from the list. 

 

4. Confirm with "OK". 
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2.2.2 Set up of the communication settings of the device 

 

 

1. Enter a valid IP Address. 

2. Enter a valid subnet mask. 

3. Execute command "Assign IP Configuration". 

4. Enter a valid device name. 

5. Execute command "Assign Name". 

6. Close the Edit Ethernet Node window. 
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2.2.3 Check settings 

1. Check the settings via command "PLC" > "Display Accessible Nodes". 

 
2. Select node "siko-ag2x-165". 

3. Execute command "Edit" > "Object Properties…". 

4. Now the actual settings are shown. 

 

5. Confirm "OK". 

6. Close the Accessible Nodes window. 
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3 Software configuration 

3.1 Import SIKO library 

1. Execute command "File" > "Retrieve". 

2. Choose library SIKO_AG2X_VXXX.zip. 

3.2 Add required function blocks 

Add OB82, OB86 and OB122 to the folder "Blocks". 

1. Select folder "Blocks". 

2. Execute command "Insert" > "S7 Block" > "1 Organization Block". 

 
3. Enter organization block name "OB82". 

 
4. Repeat steps 2 and 3 with block name "OB86" and "OB122". 
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3.3 Call SIKO function block cyclically 

1. Double click on "OB1". 

2. Add function block FB100 from library to main program. 

 

3. Enter the name "DB100" for instance data block. 

 
4. Confirm the message window with "Yes". 
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3.3.1 Setup the input and output addresses of the SIKO function block 

To setup the input and output addresses of the function block the decimal address values from 
the hardware configuration have to be converted to hexadecimal values. 

 

In this example the conversion table looks like this: 

ControlWord 257…258dec AdrControlWord W#16#101 

TargetValue 259…262dec AdrTargetValue W#16#103 

DigitalOutputs 256dec AdrDigOutControl W#16#100 

StatusWord 257…258dec AdrStatusWord W#16#101 

ActualValue 259…262dec AdrActualValue W#16#103 

DigitalInputs 256dec AdrDigInStatus W#16#100 

The input "ID" of the function block must be connected with the address of slot number 4. 

In this case the address equals the address of the StatusWord DW#16#101. 

After set up of the addresses save the settings and close the editior window. 

  



Software configuration 

AG25, AG26 Date: 21.09.2018  Mod. status V1.1 Page 16 of 28 

3.4 Enter symbol name for data block 

1. Select "DB100". 

 
2. Execute command "Edit" > "Object properties…". 

 

3. Enter the symbolic name "PAR_data_AG2X". 

4. Confirm the input with "OK". 
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3.5 Variable table for testing 

3.5.1 Insert variable table 

1. Execute command "Insert" > "S7 Block" > "6 Variable Table". 

 
 

2. Enter the symbolic name "VAT_100". 

 

3. Confirm the input with "OK". 

4. Select "VAT_100". 
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5. Execute command "Edit" > "Open Object". 

3.5.2 Choose variable table for import 

1. Execute command "Insert" > " Variable Table…". 
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3.5.3 Edit paste options for variable table import 

 
1. Choose Entry point: Library. 

2. Choose Name "SIKO_AG2X_VXXX". 

3. Choose Folder "Blocks". 

4. Select "VAT_100". 

5. Confirm settings with "OK". 

6. Save the settings and close the variable table window. 

3.6 Download project to PLC 

Execute command "PLC" > "Download". 
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3.7 Software example 

3.7.1 Parameter access 

The present module contains the parameter data in addition to the process data (CW/SW). 
Parameters that can be changed (read/write) exist in programming as actual value (_r) and as 
target value (_w) as well. Furthermore, it is differentiated between pure read parameters (only 
indicated as actual value) and pure write parameters (only indicated as target value). 

A rising edge must be applied either to the "Cmd_Start_read" or to the "Cmd_Start_write" 
input on the module described here in order to enable a read or write process of one of the 
variables. 

3.7.2 Read parameters 

If a rising edge is applied to the "Cmd_Start_read" input, then all parameters will be read and 
can be used for further programming. If counter read value is not reset to "0" the read cycle 
was interrupted by read failure. This indicates to a communication failure. 

3.7.3 Write parameters 

If a rising edge is applied to the "Cmd_Start_write" input of the module, then all parameters 
will be transferred to the drive. If counter write value is not reset to "0" the write cycle was 
interrupted by a write failure. This indicates to a communication failure or parameter value is 
beyond range of value accepted by drive. 

3.7.4 Copy parameters from read to write 

If a rising edge is applied to the "Cmd_Start_copy" input of the module, then all actual values 
(_r) are copied to their corresponding target values (_w). 

3.7.5 S-Commands 

After executing a S-Command a read cycle must be triggered manually to refresh all actual 
values (_r). 
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3.7.6 Counter value 

Count 
read 
value 

Count 
write 
value 

Name Value range (dec) Default 

1 1 LED Functionality 0 … 1 0 

2 2 Service Interface Baudrate 0 … 3 1 

3 3 Digital Output 1 Functionality 0 … 3 0 

4  Digital Output Functionalities State  - 

5 4 Digital Outputs Polarity 0 … 15 0 

6 5 Digital Input 1 Functionality 0 … 11 0 

7 6 Digital Input 2 Functionality 0 … 11 0 

8 7 Digital Input 3 Functionality 0 … 11  0 

9 8 Digital Input 4 Functionality 0 … 11 0 

10  Digital Input Functionalities State  - 

11 9 Digital Inputs Polarity 0 … 15 0 

12 10 Controller Parameter P 1 … 500 300 

13 11 Controller Parameter I 0 … 500 2 

14 12 Controller Parameter D 0 … 500 0 

15 13 A-Pos 1 … 100 50 

16 14 V-Pos Gear 
66:1 ⇒ 1 … 75 rpm 
98:1 ⇒ 1 … 50 rpm 
188:1 ⇒ 1 … 30 rpm 
368:1 ⇒ 1 … 15 rpm 

10 

17 15 D-Pos 1 … 101 101 

18 16 A-Rot 1 … 100 50 

19 17 A-Inch 1 … 100 50 

20 18 V-Inch Gear 
66:1 ⇒ 1 … 75 rpm 
98:1 ⇒ 1 … 50 rpm 
188:1 ⇒ 1 … 30 rpm 
368:1 ⇒ 1 … 15 rpm 

10 

21 19 Pos Window 0 … 1000 10 

22 20 Gear Ratio Numerator 1 … 10000 1 

23 21 Gear Ratio Denominator 1 … 10000 1 

24 22 Spindle Pitch 0 … 1000000 0 

25 23 Calibration Value -999999 … 999999 0 

26 24 Software Limit 1 -9999999 … 9999999 99999 

27 25 Software Limit 2 -9999999 … 9999999 -19999 

28 26 Delta Inch -1000000 … 1000000 720 

29 27 Sense of Rotation 0 … 1 0 

30 28 Pos Type 0 … 2 0 

31 29 Operating Mode 0 … 1 0 

32 30 Inching 2 Stop Mode 0 … 1 0 
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Count 
read 
value 

Count 
write 
value 

Name Value range (dec) Default 

33 31 Inpos Mode 0 … 2 0 

34 32 Loop Length 0 … 30000 360 

35 33 Contouring Error Limit 1 … 30000 400 

36 34 Current Limiting 25 … 110 110 

37 35 Inching 2 Offset 10 … 100 100 

38 36 Inching 2 Acceleration Type 0 … 1 0 

39 37 Offset Value -999999 … 999999 0 

40 38 PCM Position 1 DINT 0 

41 39 PCM Position 2 DINT 0 

42 40 PCM Position 3 DINT 0 

43 41 PCM Position 4 DINT 0 

44 42 PCM Position 5 DINT 0 

45 43 PCM Position 6 DINT 0 

46 44 PCM Position 7 DINT 0 

47 45 PCM Acceleration 1 1 … 100 50 

48 46 PCM Acceleration 2 1 … 100 50 

49 47 PCM Acceleration 3 1 … 100 50 

50 48 PCM Acceleration 4 1 … 100 50 

51 49 PCM Acceleration 5 1 … 100 50 

52 50 PCM Acceleration 6 1 … 100 50 

53 51 PCM Acceleration 7 1 … 100 50 

54 52 PCM Velocity 1 Gear 
66:1 ⇒ 1 … 75 rpm 
98:1 ⇒ 1 … 50 rpm 
188:1 ⇒ 1 … 30 rpm 
368:1 ⇒ 1 … 15 rpm 

10 

55 53 PCM Velocity 2 see PCM Velocity 1 10 

56 54 PCM Velocity 3 see PCM Velocity 1 10 

57 55 PCM Velocity 4 see PCM Velocity 1 10 

58 56 PCM Velocity 5 see PCM Velocity 1 10 

59 57 PCM Velocity 6 see PCM Velocity 1 10 

60 58 PCM Velocity 7 see PCM Velocity 1 10 

61 59 PCM Deceleration 1 1 … 101 101 

62 60 PCM Deceleration 2 1 … 101 101 

63 61 PCM Deceleration 3 1 … 101 101 

64 62 PCM Deceleration 4 1 … 101 101 

65 63 PCM Deceleration 5 1 … 101 101 

66 64 PCM Deceleration 6 1 … 101 101 

67 65 PCM Deceleration 7 1 … 101 101 

68  Output Stage Temperature  - 

69  Voltage of Control  - 
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Count 
read 
value 

Count 
write 
value 

Name Value range (dec) Default 

70  Voltage of Output Stage  - 

71  Voltage of Battery  - 

72  Motor Current  - 

73  Actual Position  - 

74  Actual Rotational Speed  - 

75  Serial Number  - 

76  Production Date  - 

77  SW Motor Controller  - 

78  Gear Reduction  - 

79  System Status Word  - 

80  Encoder Resolution  - 

81  Device ID  - 

82  Number of Errors  - 

83  Error Number 1  - 

84  Error Number 2   - 

85  Error Number 3  - 

86  Error Number 4  - 

87  Error Number 5  - 

88  Error Number 6  - 

89  Error Number 7  - 

90  Error Number 8  - 

91  Error Number 9  - 

92  Error Number 10  - 

 66 S Command 0 … 8 0 

3.7.7 Error codes 

The "status" output parameter contains error information. If it is interpreted as 
ARRAY[1…4] OF BYTE , the error information has the following structure: 

Field element Name  Meaning 

status[1] Function_Num B#16#00, if no error 
Function ID from DPV1-PDU:  
If an error occurs, B#16#80 will be output (for read data 
record: B#16#DE, for write data record: B#16#DF). 
If no DPV1 protocol element is used: B#16#C0 

status[2] Error_Decode Location of the error ID 

status[3] Error_Code_1 Error ID 

status[4] Error_Code_2 Manufacturer-specific error ID extension 
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3.7.7.1 Field element status[2] 

status[2] can have the following values: 

Error_Decode  
(B#16#…) 

Source Meaning 

00 to 7F CPU No error or no warning 

80 DPV1 Error according to IEC 61158-6 

81 to 8F CPU B#16#8x shows an error in the xth call parameter of the 
instruction 

FE, FF DP profile Profile-specific error 
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3.7.7.2 Field element status [3] 

Error_Decode  
(B#16#…) 

Error_Code_1 
(B#16#...) 

Explanation 
according to 
DPV1 

Meaning 

00 00  No error, no warning 

70 00 reserved, reject Initial call; no active data record transfer 

70 01 reserved, reject Initial call; data record transfer has 
started 

70 02 reserved, reject Intermediate call; data record transfer 
already active 

80 90 reserved, pass Invalid logical start address 

80 92 reserved, pass Illegal type for ANY pointer 

80 93 reserved, pass The DP component addressed via ID or 
F_ID is not configured 

80 95  Error when reading additional interrupt 
information (when reading out 
additional interrupt information for 
central or distributed I/O via an external 
DP interface, this error will be output as 
a "group error".)  
Note: During link-up and update, the 
additional interrupt information may not 
be available temporarily. 

80 96  The master CPU is in STOP mode. At that 
time, an OB was being processed. The 
instruction "RALRM" cannot supply the 
OB start information, the management 
information, the header information, or 
the additional interrupt information. 
The OB start information can be read 
with the "RD_SINFO" instruction. In 
addition, you can use the "DPNRM_DG" 
instruction to asynchronously read the 
current diagnostics frame of the affected 
DP slave for OBs 4x, 55, 56, 57, 82, and 
83 (address information from the OB 
start information). 

80 A0 read error Negative acknowledgment while reading 
the module. 

80 A1 write error Negative acknowledgement when writing 
to the module 

80 A2 module failure DP protocol error at layer 2 (e.g., slave 
failure or bus problems) 

80 A3 reserved, pass PROFIBUS DP: DP protocol error with 
Direct-Data-Link-Mapper or User-
Interface/User 
 
PROFINET IO: General CM error 



Software configuration 

AG25, AG26 Date: 21.09.2018  Mod. status V1.1 Page 26 of 28 

Error_Decode  
(B#16#…) 

Error_Code_1 
(B#16#...) 

Explanation 
according to 
DPV1 

Meaning 

80 A4 reserved, pass Communication on the communication 
bus disrupted 

80 A5 reserved, pass - 

80 A7 reserved, pass DP slave or module is occupied 
(temporary error) 

80 A8 version conflict DP slave or module reports non-
compatible versions 

80 A9 feature not 
supported 

Function is not supported by DP slave or 
module 

80 AA to AF user specific DP slave or module reports a 
manufacturer-specific error in its 
application. Please check the 
documentation from the manufacturer of 
the DP slave or module. 

80 B0 invalid index Data record not known in module  
Illegal data record number ≥ 256 

80 B1 write length 
error 

The length specified in the RECORD 
parameter is incorrect; 
 
With "RALRM": length error in AINFO, 
 
With "RDREC" and "WRREC": length error 
in MLEN 

80 B2 invalid slot The configured slot is  not occupied. 

80 B3 type conflict Actual module type  does not match  
specified module type 

80 B4 invalid area DP slave or module reports access to an 
invalid area 

80 B5 state conflict DP slave or module not ready 

80 B6 access denied DP slave or module denies access 

80 B7 invalid range DP slave or module reports an invalid 
range for a parameter or value 

80 B8 invalid 
parameter 

DP slave or module reports an invalid 
parameter 

80 B9 invalid type DP slave or module reports an invalid 
type 
 
With "RDREC": buffer too small (subsets 
cannot be read) 
 
With "WRREC": buffer too small (subsets 
cannot be written) 
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Error_Decode  
(B#16#…) 

Error_Code_1 
(B#16#...) 

Explanation 
according to 
DPV1 

Meaning 

80 BA to BF user specific DP slave or module reports a 
manufacturer-specific error when 
accessing. Please check the 
documentation from the manufacturer of 
the DP slave or module. 
 
Note on value B#16#BA: The following 
applies for PROFINET in the H system: If 
a data record job with the return value 
W#16#80BA is rejected, the job must be 
repeated. 

80 C0 read constrain 
conflict 

With "WRREC": the data can only be 
written when the CPU is in STOP mode. 
Note: this means that writing by the user 
program is not possible. You can only 
write the data online with PG/PC. 
 
With "RDREC": the module routes the 
data record, but either no data is present 
or the data can only be read when the 
CPU is in STOP mode. Note: if data can 
only be read when the CPU is in STOP 
mode, then an evaluation by the user 
program is not possible. In this case, 
you can only read the data online with 
PG/PC. 

80 C1 write constrain 
conflict 

The data of the previous write job on the 
module for the same data record have 
not yet been processed by the module. 

80 C2 resource busy The module is currently processing the 
maximum possible  number of jobs for a 
CPU. 

80 C3 resource 
unavailible 

The required operating resources are 
currently occupied. 

80 C4  Internal temporary error. Job could not 
be carried out. 
 
Repeat the job. If this error occurs often, 
check your installation for sources of 
electrical interference. 

80 C5  DP slave or module not available. 

80 C6  Data record transfer was canceled due to 
priority class cancellation 

80 C7  Job aborted due to warm or cold restart 
on the DP master 
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Error_Decode  
(B#16#…) 

Error_Code_1 
(B#16#...) 

Explanation 
according to 
DPV1 

Meaning 

80 C8 to CF  DP slave or module reports a 
manufacturer-specific resource error. 
Please check the documentation from 
the manufacturer of the DP slave or 
module. 

80 Dx user specific DP slave specific. Refer to the 
description of the DP slave. 

8x (x=1, … 
9,A,B,C,D,E,F) 

00 to FF  Error in y-th call parameter (y = 1, ...15) 
 
Error_Code_1 = 00: Illegal operating 
mode 
 
For all other values of Error_Code_1 refer 
also to: Evaluating errors with output 
parameter RET_VAL 

FE, FF 00 to FF  Profile-specific error 

 

3.7.7.3 Field element status [4] 

In PROFINET IO, status[4] has the value 0 
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